安装easywechat 遇到的坑

作者:😬 🐒 更新时间:2019-09-09 23:01:02 浏览次数:3661

温馨提示:当前尚未登录,请先登录后才能下载,评论,收藏和分享

  • 收藏
  • 评论
  • 分享

先介绍一波,这个框架简化了我们从事微信开发的工作,各种授权,换取code ,换token 过期维护,回调处理,返回值加密解密 ,都做的很好。

对我开发者来说,就是调用几个函数就可以,十分简单。

EasyWeChat 是一个开源的 微信 非官方 SDK。

EasyWeChat 的安装非常简单,因为它是一个标准的 Composer 包,这意味着任何满足下列安装条件的 PHP 项目支持 Composer 都可以使用它。

环境需求

首先以上这些扩展必须提前安装。

然后php版本的问题,如果你在linux 环境中,你有多版本php时,要注意cli环境中php的version 和 项目运行环境的php 版本是不是都是PHP >= 7.0

接下来运行项目 你可能会遇到 类似于这个错误

interfaces psr/simple-cache  not found

这个是easywechat做缓存需要依赖的一个包。

所以你还需要执行 composer require psr/simple-cache

好了,安装结束。开始引入吧,愉快的开发。

发布评论:

提 交